The ScopeSET Support and Community Portal
         
View all tags
Tags:    No tags associated yet.
Go Back
Tracker: ECRs Priority: High Type: Bug
Found: 10.0 Status: Closed Target: 10.0
OS: All Fixed: 10.0 PatchID: --
Description:
2005-06-02 16:04:28 wachsmuth
The following part of the Ada Code generator instead ToState delivers FromState. The split operation delivivers the ID of a transition. In the loop ToState and FromState are exchanged. The IMF File is correct.

proc getToStateId(pathName)
local x = "getToStateId_" [pathName];
if ([[x]] != "")
return [[x]];
end if
loop (Instances->MTransition(split([[pathName]]," ","T"))->ToState )

// The following loop delivers ToState
// loop (Instances->MTransition(split([[pathName]]," ","T"))->FromState As ToState)

info = "getToStateId("[pathName]") /"[[pathName]]"/ -> "[ToState.id]" = "[ToState.name]" Tid="[MTransition.id]"\n";
[[x]] = [ToState.id];
return [[x]];
end loop
info = "ERROR: getToStateId("[pathName]") -> <null>\n";
end proc
2005-06-06 10:12:45 amueller
To clarify: According to Klaus, the navigation returns an "inverted" result. (swapping ToState and FromState


in TDL is only a workaround for a problem in ACD itself) - which seems to be a 10.0 regression.
Details:
Children (0)
Associations (0)
All (0)

Submitted Type Wiki Link Target Comment
Nothing found to display.

Submitted Type Wiki Link Source Comment
Nothing found to display.