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Welcome to Ameos
Welcome to the Ameos Unified Modeling Language (Ameos/UML) guided tour. This brief tour takes you
through an example Ameos system created in Ameos/UML, illustrating key Ameos features and support
of UML
For the purposes of this tour, we assume that you have a copy of Ameos installed on your computer as
well as a valid Ameos license installed. For installation information, please refer to Installing Ameos for
<platform>.
For additional information, please consult the online documentation, visit our web site located at http://
www.aonix.com, or call one of the Support numbers shown by choosing Technical Support from the
Help menu on the Ameos desktop.

About Ameos/UML
Ameos/UML provides system architects, analysts, designers, and developers with a powerful visual modeling and deployment environment, including tools to model, design, implement, and maintain next-generation systems and applications.
It comprises product-specific modeling, reporting, and implementation applications that share a common
architecture built around a central database repository. Ameos supports the following UML diagrams:
Use case
Class
Sequence
Collaboration
State
Activity
Component
Deployment
Profile (UML 2.0 profile)
For information on the latest features of Ameos, see the Release Notes.

Starting Ameos
You are ready to start Ameos and begin exploring the example system, uml_email, which models an electronic mail system application.

Starting Ameos from UNIX
To start Ameos from the UNIX command line:
1. Source the setup-ameos script, as needed.
cd ameos_<version>
source setup-ameos.<shell>
where <shell> is .sh or .ksh.
2. Type:
ameos
3. When the selection dialog appears, double-click uml_email (or select it and click Open).
The Ameos desktop appears, with the name of the opened system in the desktop title bar (see the figure
on the next page).
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If you have problems starting Ameos, refer to Installing Ameos for UNIX Platforms.

Starting Ameos from Windows
To start Ameos from Windows:
1. From the Windows Start menu, choose Programs > Aonix Ameos <version> > Ameos/UML
<license type>, where <license type> is Analyst, Modeler, or Developer, depending on the license you
have purchased.
2. When the selection dialog appears, double click uml_email (or select it and click Open).
The Ameos desktop appears, with the name of the opened system in the desktop title bar (see the figure
below).
If you have problems starting Ameos, refer to Installing Ameos for Windows Platforms.

Resizing the Desktop (optional)
When you open the desktop for the first time, it appears in full-screen mode, with all windows visible and
docked in their default locations, as shown below.
•

You may resize the desktop as desired.
The top screen, below the menu icons, is the main desktop window. It is permanently docked. The three
subwindows below that can be undocked or closed as desired. Once you have resized the desktop, you
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may resize the subwindows as desired. To do so, grab the double vertical lines to the left of the subwindow and drag the window to another location. To close a subwindow, click on the ’x’ at the top of the vertical lines (or choose View > Hide <window>).

Opening a Diagram
From the Ameos desktop, you can perform operations such as start editors, open diagrams, and generate code and documentation.
To open a diagram from the example system uml_email:
1. In the model pane (pane on the left side of the Ameos main window), open the Diagrams category to
see the Ameos/UML diagram types.
•

2. For this example, select the diagram type Use Case.
A list of use case diagrams for the uml_email example system appears in the objects pane to the right
of the model pane.
3. In the objects pane, double-click on EmailSystem. The use case editor opens in full-screen mode.
You may resize the editor and move or close subwindows. At this point, you may want to reposition
the diagram inside the drawing area. To do so, choose View > Fit Diagram in Drawing Area.
The figure below shows the main window of the use case editor, with the EmailSystem use case diagram centered in the drawing area. (Note that the default configuration includes the panner/find and
message log windows in their docked positions. The figure below does not show those two windows.)
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•

Note the various areas of the editor window. Under the title bar is the set of menu functions (File, Edit,
etc.).
Below that are the standard toolbar icons for the editor; all diagram editors have the same set. (See the
figure below.) Pass your cursor over each icon to see what each icon represents. Press the double
arrows pointing right; this causes the remaining icons to be displayed. On the left are icons for drawing
diagrams; these vary according to editor.
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•

Standard Toolbar

Symbols Toolbar

Default Arc Toolbar

Viewing and Aligning Parts of a Diagram
Ameos provides some helpful tools and commands for viewing and aligning parts of a diagram.

Using the Zoom Toolbar Buttons
With the zoom buttons on the toolbar, you can enlarge, shrink, and center a diagram or a portion of a diagram in the drawing area.
•

Zoom In
Zoom Out
Zoom To Fit

Try it:
1. Select a use case symbol in the use case diagram and click the Zoom To Fit toolbar button. Ameos
enlarges and centers the selected part of the diagram. (This is the same as choosing View > Fit
Selection in Drawing Area.)
2. To re-center and fit the entire diagram in the drawing area, click anywhere on the blank “canvas” of
the drawing area (not on any symbol) and click the Zoom To Fit button again. (This is the same as
choosing View > Fit Diagram in Drawing Area.)
You can also resize the diagram by zooming in or out, using the Zoom In and Zoom Out toolbar buttons.

Using the Diagram Panner
Ameos provides the diagram panner for viewing very large diagrams and for viewing different areas of a
zoom-enlarged diagram:
1. Once again, select a Use Case symbol in the diagram and click Zoom To Fit to enlarge a small area
of the diagram.
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2. From the View menu, choose Show Panner/Find Window.
A window (the “panner”) appears, displaying a miniaturized view of the current diagram, with a rectangular outline called the “bounding box” positioned over the selected symbol. The figure below is an
undocked view of the panner/find window; in its default configuration, this window is docked below the
main window, to the right of the message log window.
•

3. Use the mouse to drag the bounding box around the miniaturized diagram in the panner.
Ameos repositions the diagram in the editor’s drawing area accordingly.
4. Close the panner (click the x – in the figure above, it’s in the upper-right corner).

Aligning Objects
Ameos makes organizing your diagram easy by providing numerous ways to align objects and links automatically:
1. In the use case diagram, select the Create User use case and drag it out of position, so that it is no
longer aligned with the adjacent use cases.
2. Hold down the Shift key and additionally select the two use cases, Create Conference and Delete
User or Conference.
3. Click the Align toolbar button.
(Or, choose Align from the Tools menu.)
4. In the Align dialog box, make the following selections:
• In the Symbol Spacing group, select vertical Equal Distances.
• In the Symbol Alignment group, select Horiz. Center. Click OK.
Ameos realigns the selected objects.
Note: To undo any results you do not like, choose Undo from the Edit menu, as needed, to restore
the diagram to its previous state.

Editing a Use Case Diagram
The use case diagram shows the major capabilities of the system as seen by the outside world. Use
cases provide a means for expressing high-level interactions with the system. Typically, these interactions involve a sequence of transactions that are initiated by a system user (called an actor) when using
the system.
In the EmailSystem use case diagram, the large rectangle (with the words “This System” in the outside
upper-right corner) represents the entire Email system.
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Moving and Enlarging Elements in the Diagram
Before editing this diagram, make sure the Email system rectangle is large enough to accommodate a
few more use cases:
1. Click on the Email system symbol to display its “handles”; then drag one of the right-side handles to
the right to enlarge the rectangle.
All use cases should appear totally within the rectangle, and there should be extra room for inserting
additional symbols. Actor symbols should remain outside the Email system symbol.
2. If needed, reposition any use case or other symbols, using the left mouse button to select and drag
the symbol to the desired location.
3. To re-center and re-size the entire diagram, click anywhere in the blank area outside of the Email system rectangle, then click the Zoom To Fit button on the toolbar.

Adding a Single Use Case
To add another use case to this diagram:
1. With the left mouse button, select the Use Case symbol on the vertical Symbols toolbar to the left of
the drawing area.
•

Symbols Toolbar

Use case

2. Click the left mouse button somewhere in the lower half of the Email system rectangle.
A new use case symbol appears in the diagram, with an input text box for label entry.
3. In the text box, type a label for the use case and press Enter.
Alternatively, choose Edit > Choose Use Case Symbol Name to label the symbol. In the Choose
Name dialog that appears, choose one of the names listed, or enter the name in the Selection field
and click OK.

Inserting Multiple Symbols
To add and label multiple instances of a symbol (for example, a use case):
1. Double-click the Use Case symbol on the Symbols toolbar to enter multiple insert mode.
2. Click the left mouse button in the drawing area repeatedly to create as many use cases as needed,
labeling each one as created.
3. Click the Selection Tool on the Symbols toolbar to terminate multiple insert mode.
•

Selection Tool
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Note: To edit a completed label, select the symbol and press F2 to display its text box, then retype or
edit the label and press Enter.

Linking Elements
To link the new use case to other elements in the diagram:
1. Select the Communicates arc type on the Default Arc Type toolbar (diagonal line with a C) with a single click.
•

Communicates

2. Click the System Administrator actor symbol in the diagram to attach one end of the arc.
3. Move the pointer to the new use case symbol and click again to attach the other end of the arc.
4. To draw multiple links without re-selecting the arc symbol each time, double-click the Communicates
arc, then draw the arcs. Click the Selection Tool or any other symbol on the Symbols toolbar to terminate multiple insert mode.
Try it now. Draw an arc from an actor to a use case; then draw an arc between use cases.
Note: Unless you specifically selected a new arc type from the Default Arc Type toolbar, Ameos uses
either the previously set arc type or a default arc type for the particular link you are drawing.

Changing an Existing Link’s Arc Type
To change the arc type of an existing link:
1. Select the "include" link between the Send_Message and Forward_Message use cases.
2. From the Edit menu choose Replace or use the context (right-click) menu.
3. In the Replace Arc Type dialog box, select a different arc type and click OK.
The arc type of the selected link in the diagram changes to whatever you chose as the replacement
arc type.
4. Select Edit > Undo to undo the operation. (You probably do not want to change the link permanently
at this time.)

Describing a Use Case
You can add textual information to a use case (or other diagram element) to describe more detailed
behavior.
1. In the EmailSystem use case diagram, select any use case.
2. From the context menu, choose Object Description.
3. In the text editor that opens, enter your description, then choose File > Save.
The description is saved in an object annotation note.

Changing Use Case Properties
You can change or extend the properties of use cases (and other diagram elements) by using the element’s "properties window." This feature is available with all Ameos editors. To illustrate the properties
window, we will change the color of a use case and add an annotation (an external file link) to it.
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Changing Color
Ameos allows you to change the color of various symbols so that you can visualize the semantics of your
model. Whenever a model element is referenced in a UML diagram, it will show up in the same color.
To change the color of a use case:
1. Select the Send_Message use case in the EmailSystem use case diagram. Choose Edit > Properties.
The properties window opens, with the Object tab on top.
•

2. Click the browse button to the right of the Color field.
3. Click on a color, then press OK.
4. Press Apply in the properties window to apply the change.
The use case is displayed in the selected color.

Adding External File Links
With Ameos, you can link external files to an Ameos element. To try this, first create some text in an
Ameos-supported external file editor or word processor and save the file.
To link the external file to an object:
1. If the Send Message properties window is not open already, open it (Edit > Properties).
2. Click the Annotations tab.
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•

3. Select the Object note from the Defined Annotations pane, right click and choose Add Item > External File.
An External File item appears beneath the Object note.
4. Double-click the External File item to open the Value field. Enter the name of the file or use the
browse button to select the file from the selection dialog. Click Open. The file name is added to the
Value field.
5. Click Apply to apply the changes.
(Note that the Color item (under the Object note) is now set to the code representing the color of the use
case we changed above.)
To view the contents of the external file, right-click the External File item and choose Open. The file
opens in the appropriate editor (if supported by Ameos).

Modeling a Scenario in a Sequence Diagram
Given a particular task represented by a use case, a variety of scenarios could occur that the system
must be able to handle. For example, the Send_Message task needs to handle scenarios in which a user
attempts to send a message to either an invalid user or a valid user. Each of the different scenarios can
be modeled in an interaction diagram.
There are two types of interaction diagrams:
•

Sequence diagrams, which emphasize the order of message passing between interacting objects

•

Collaboration diagrams, which emphasize the structure of the interaction

In this tour, we’ll explore the use of the sequence editor for modeling the scenario of sending a message
to a valid user:
1. In the use case diagram, select the Send_Message use case.
2. From the GoTo menu, choose Scenario in Sequence Diagram. The sequence editor opens, with
the Object Selector dialog on top.
3. In the Object Selector dialog, double-click uservalid or select it and click OK. (You can also create a
new scenario here by clicking on <<Create New Scenario for Use Case>>.)
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The user valid(UMLUseCase:Send_Message) scenario appears in the Send_Message_1 sequence
diagram in the sequence editor.

4. In the sequence diagram, select the send_msg message and choose Properties from the main menu
or from the shortcut (right-click) menu. Or, you can click the Properties toolbar button.

Properties

5. Examine the properties window that appears and experiment with entering more detailed information
for the selected message.

6. Click Apply when finished.
7. Click the Refresh Display Marks toolbar button (run your cursor over the buttons to see which one it
is).
A Quick Tour of Ameos/UML
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Note: Some display marks may be turned off. To set the visibility of display marks, choose Tools >
Options and select the Display Marks tab at the top of the dialog that appears. In the dialog, set the
display marks as desired and click OK.
8. Save the diagram (File > Save).

Using the Class Editor
The class diagram shows the static relationship between the objects and/or classes in the system. The
class table portion of the class editor provides additional information about the classes in the class diagram.

Navigating to a Class Diagram
You can open a new class diagram by clicking on the Class diagram type in the model pane of the desktop, right-clicking, and then choosing New from the context menu. You can open an existing class diagram from the Ameos desktop by clicking the Class diagram type in the model pane and then selecting a
class from the objects pane. Once the diagram is open, you create a new class by selecting the Class
symbol from the Symbols toolbar and pasting it into the drawing area.

Class

But here we will be opening an existing class diagram by navigating to the diagram from the sequence
diagram we opened previously.
To navigate to a class diagram from the sequence diagram:
1. In the sequence diagram, select the User: object in the drawing area.
2. From the GoTo menu, choose Class Diagram Where Class Is Referenced.
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•.

Part of the class diagram appears in the editor’s drawing area, with the User class selected. The rest
of the diagram may not be visible.
3. Click anywhere in a blank area of the drawing “canvas” (not on any object) and click the Zoom To Fit
toolbar button to re-center and re-size the diagram.

Auto Drawing Classes
Ameos can automatically draw and construct classes for you from data already available in the repository.
1. Select the Message class.
2. From the UML menu, choose Auto Draw > Draw Associated Class(es) > into new diagram.
Ameos opens a new diagram and draws and labels class symbols for the Message class and its
associated classes. No attributes or operations are shown.
3. Select the Message class in the new diagram.
4. From the UML menu, choose Attributes and Operations > Select Members to Display. In the dialog, check the names of the attributes and operations you wish to display, then click OK.
Ameos reconstructs the Message class, with all of its members, from the relevant information in the
repository.
5. Construct the Mailbox class from all definitions, repeating the instructions in the previous step.
6. Rearrange the objects as desired.
Note: If you need to resize a class to include its attributes and operations and are unable to drag a corner, select the class, choose Current Symbol Options from the context (right click) menu, then make
sure Shrink around label and Expand when label grows are turned off. Then resize the symbol width
and height in the dialog as needed.

Editing Role Names, Multiplicity, and Navigability
To enter or edit role names, choose predefined multiplicities, and represent bidirectional navigability of an
association:
1. On the class diagram, select an association.
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2. Display the association’s property sheet, using the Properties toolbar button or the Properties command on the Edit or context menu.
•

3. In the Associated Classes tab, enter or edit role names in the Role fields, as desired.
4. Display the options list in a Multiplicity field for an associated class and either:
• Select a predefined multiplicity from the list.
• Manually type any allowable entry in the adjacent text entry field on the property sheet.
5. Set the Role Navigability options as desired:
• For unidirectional navigability, clear the Role Navigability option for one of the association roles.
• To reestablish bidirectional navigability, set or unset role navigability on both ends of the association.
6. Click Apply.

Viewing More Information About Classes
Various display marks appear on the diagram, each representing additional information, usually in the
form of an assigned property or annotation for that object.
For example:
•

Integers that compose a multiplicity display mark on an association arc represent the lower and upper
bounds of the multiplicity.

•

A state machine icon display mark indicates that the class has a state machine associated with it.

•

Display Mark

In addition, you can view information about the class in the "members view" of the class. To do so:
1. Select the Mailbox class and choose Properties from the Edit menu (or from the context menu).
The properties window for the class appears. Click the Members tab. It contains language-specific
details of the class, presented in tabular format.
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•

2. To widen a column to fit the existing labels, click the bar between the column numbers (e.g., the bar
between 2 and 3), then drag the column to the desired width.
3. To select a row or column, click the row/column number.
4. To enlarge the window, grab a corner, then drag as desired.
5. To view portions of the table that are currently hidden (without resizing), use the horizontal and vertical slider arrows.
6. To view another portion of the Members tab, click on the subtabs at the bottom of the window (e.g.,
C++ Items).
7. To perform various table operations such as Save, Insert Row Before/After, or Delete Row, click the
appropriate button to the left of the subtabs.
8. When you’ve finished examining the table, click Apply if you’ve made changes. Or click the X button
on the upper right of the window.
You can do many other things in the class members view. One of the more important is adding attributes
and operations to the class.
To do this,
1. Select a row in the Attribute or Operation section.
2. Click the Insert Row Before or Insert Row After button at the bottom left. A new Attribute or Operation
row is added.
3. Fill in the name of the attribute or operation and insert/edit parameters (e.g., Type or Default Value) as
appropriate.
To specify the arguments of an operation, click in the Arguments cell of the new operation and choose
Edit Signature from the context menu.
4. Click Apply when finished. The new attribute or operation appears in the class diagram.
Note: You can use UML > Attributes and Operations > Select Members to Display to specify which
members are displayed in the diagram.

Checking Syntax and Semantics
You can apply the following types of checks to a class diagram:
•

Syntax check—Verifies that all diagrams are syntactically complete and correctly drawn; that is, all
objects are properly labeled and all connection rules have been followed.
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•

Semantic check—Verifies that all objects are properly defined in the repository according to methodological constraints, and all elements are properly balanced.

Note: You can also check syntax and semantics for diagrams in other editors or for your entire model.
But here we will use the class diagram.
1. Open the class diagram named Application_1 from the desktop.
2. From the class editor’s Tools menu, choose Check Syntax. Or, click the Check Syntax toolbar
icon.
A message in the editor window’s status area (lower left) verifies that there are no syntax errors in the
diagram.
3. From the class editor’s Tools menu, choose Check Semantics. Or, click the Check Semantics toolbar icon.
A semantic check ensures consistency across the entire model of the modeling constructs present in
the diagram being checked. This check will report some errors, visible in the message log.
4. In the message log, scroll to and select the error message for class Session, which is highlighted in
the following figure; then click the Go To Error Origin button.
•

The Session class appears selected in the class diagram.
To correct the error, we’ll define a type for the attribute start_time, belonging to class Session, in the
members view.
5. Open the properties window for Session by choosing Edit > Properties, then click the Members tab.
6. In the Members tab for Session, select the empty cell in the Type column for the attribute start_time.
7. Enter ’Int’ in the cell and click Apply.
The Members tab for Session should now look like this:
•

The type will appear in the diagram as well, if the AttributeTypeAndValue display mark is set to diaplay.
8. From the File menu, choose Save.
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9. Close the class table and return to the class diagram; then rerun the Check Semantics command.
This time the message log should report one less error.

Using the State Editor
The state diagram shows the potential states of an object and the events that transform the object from
one state to another.

Navigating to a State Diagram
To examine a state diagram, we’ll navigate to it from the class diagram:
1. On the class diagram, select the Message class.
2. From the GoTo menu, choose State Diagram for Class.
The state diagram for the Message class appears.
Note: You can browse through any diagram by positioning the pointer on various objects. The status
area (lower-left corner of the editor window) reports the type of object the pointer is on.

Modeling Substates
To model possible substates within a state, you can create a lower-level state decomposition diagram:
1. Select the message in receiver mailbox state.
2. From the Go To menu, choose Refine.
3. In the Confirmation dialog, click OK.
Ameos creates a decomposition state diagram containing a composite state symbol, labeled message in receiver mailbox.
4. Drag the top or bottom handle on the composite state symbol in the drawing area to enlarge it.
5. On the Symbols toolbar, double-click the state symbol; then click inside the composite state symbol in
the drawing area to insert and label the following substates:
• message unread
• message read
6. From the Symbols toolbar, select, insert, and optionally label initial and final state symbols within the
composite state symbol.
7. Select the State Transition Link arc type on the Default Arc Type toolbar.
8. Draw arcs between the objects in the diagram, clicking on each source and destination object in turn
to draw the arc between them.
Note: Terminate multiple insert mode by clicking the Selection Tool on the Symbols toolbar.
Your decomposition diagram should look something like this:
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•

9. Select the transition link between the initial state and the message unread substate and press F2 to
select its label.
10. Type Request delivery and then press Enter. With the link selected, choose Properties from the
context menu.
The transition link’s properties window appears, displaying the event portion of the label you just
typed in the Event field.
11. To select an existing action from the repository, click the choose button (...) adjacent to the Action
List field, select send_to_rec () and click OK on the Choose Action dialog that appears; then click
Apply on the properties window.
The label on the transition link in the diagram now appears as:
Request delivery/send_to_rec

Printing Diagrams and Reports
Ameos provides various printing and reporting capabilities, including:
•

Printing any single diagram or table directly to a default printer

•

Printing a diagram or table to a file that is formatted for viewing or printing in a supported publishing
product or web browser

•

Generating reports about your model

Printing a Diagram to a Default Printer
Let’s print one of the component diagrams to your default printer:
1. Navigate to the Ameos desktop from any diagram by choosing Show Desktop from the View menu.
Or, click the Show Desktop toolbar icon.
2. Open the Diagrams category on the desktop and select Component.
3. In the objects pane, select Application1 and click Open.
The diagram appears in the component editor.
4. From the View menu, choose Page Layout to see how the diagram will print across multiple pages
and where the page breaks will occur.
Note: Initially, page layout view may not display entire pages. Click the Zoom To Fit toolbar button to
display a complete view of the page layout for this diagram.
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•

By default, Ameos chooses a page layout for the best fit, based on default or user-specified values for
the following page setup options:
• Page orientation
• Alignment
• Diagram scale and pagination grid specifications
• Paper size
• Margins
You can edit these values from the Page Setup dialog’s Appearance or Paper options tabs. Let’s try
it.
5. Choose Page Setup from the File menu and select the Appearance option or tab at the top of the
dialog; then select the Landscape orientation and click OK.
Ameos adjusts the layout to display the diagram on a single landscape page.
6. You can change the layout so the diagram spans more than one page and make other changes as
necessary. Ameos adjusts the page layout accordingly.
7. When satisfied with the layout, click the Print toolbar button.
The Print dialog appears. Specify print options as desired, then click Print. The diagram is printed
on your default printer.

Generating a Report
Ameos allows you to generate various reports for your model. They can be tailored to your specific
needs. To explore Ameos’s reporting capabilities, you use the script manager:
1.

From the Ameos desktop, choose View > Show Script Manager to open the script manager window
(if it is not open already). Then open the Documents tab.

2. Open the Product Scripts category and then the Reports subcategory.
At this point you can choose one of the following:
• The HTML format
• One of the RTF formats (English, French, or German)
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3. In the Parameters pane, open General Parameters, then double-click on Display result to open the
Value text box. Change the value to "Yes" to view the report afterwards.
4. Right-click HTML to display its context menu. Choose Run Script. You can follow the progress of
the command in the message log.
•

5. When the script has finished, the start page of the HTML report is displayed in your default browser.
6. To view the report at another time, choose File > Open HTML Report. A selection dialog appears,
open to the correct location. Double-click on Index.html, the start page for the report. From there
you can navigate to the information you wish to view.
You can use a similar procedure to create RTF reports. To view the output, choose File > Open Report.
The report opens in Microsoft Word.

Generating Code for Your Model
Once you finish the previous exercises, you might want to generate code for your model. Ameos allows
you to generate code for your model incrementally. This means you can generate source code at any
time in your development process.
Note: The example systems provided with the Ameos installation, including uml_email, are incomplete
and purposely contain errors for users to correct.
Ameos generates code, including C++ code, by employing ACD (Architecture Component Development)
templates. To generate code, you use the script manager. The process is similar to that for generating
reports.
To generate C++ code for your model:
1. From the desktop, choose Code > Generate C++ by ACD Template. A confirmation box appears,
asking if you want to generate with the current parameters.
2. Click Yes.
The script manager opens, with C++ highlighted and code is generated automatically. You can follow
the progress of the command in the message log.
Note: If you choose to change parameters (you answer No to the generate-code question above),
change parameters as desired and then choose Run Script.
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•.

The generated code is placed in <specified_output_directory>/src_files.
ACD is discussed in the ACD Programming Guide; ACD templates are discussed in Using ACD Templates.

Now It’s Your Turn
This completes your introductory tour of Ameos. You may exit all editors and the Ameos desktop, or continue exploring Ameos’s capabilities on your own.
For more information about Aonix, please visit our web site at http://www.aonix.com.
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